Google authentication is broken
Incident Report for Zyte
Resolved
The problem with Google auth has been resolved, sorry for the inconveniences!
Posted Jun 27, 2016 - 19:25 UTC
Investigating
Google authentication to our dashboard is currently broken, we are working on restoring it
Posted Jun 27, 2016 - 17:41 UTC