Dash is currently offline
Incident Report for Zyte
Resolved
This incident has been resolved.
Posted Sep 18, 2015 - 04:36 UTC
Investigating
We are currently investigating the cause.
Posted Sep 18, 2015 - 04:00 UTC